Bisherige Updates zu MHS ASCII-Editor

Aktuelle Version: 1.51 vom 24.07.2000
Produktbeschreibung

Auf dieser Seite finden Sie Informationen zu sämtlichen bereits erstellten Updates (neueste zu oberst). Die aktuelle Version können Sie hier auch downloaden, wechseln Sie dazu einfach zum ersten Updatekasten in der Liste. Dort finden Sie einen entsprechenden Link.

Update von Version 1.5 auf Version 1.51

Korrekturen
  • Bei größeren Dateien trat der Fehler auf, daß keine Zeichen mehr eingefügt werden konnten. Dies ist nun behoben. Es können nun (theoretisch) Dateien mit max. 200.000.000 Zeichen verwendet werden.
Download


Update von Version 1.2 auf Version 1.5

Korrekturen
  • Bei der Arbeit mit der Zwischenablage gab es in der alten Version das Problem, daß Formatierungen übernommen wurden. Dies ist nun behoben.
  • Bei Markierungen (insbesondere über das Zeilenende hinaus) wurde zeitweilig ein unsinniger Wert bei der Cursorpositionsanzeige ausgegeben. Dies wurde nun damit beseitigt, daß statt der Cursorposition die Länge des markierten Textes angezeigt wird.
  • Kleiner Rechtschreibfehler: bei der Abfrage, ob noch gespeichert werden soll, sollte es natürlich "tun" und nicht "tuen" heißen.
  • Drucken: bei Auswahl von x Kopien werden nun auch x Kopien angefertigt (und nicht x*x).
  • Die Informationen für Zeilenauswahl und -breite arbeiten jetzt korrekt (Dialoge für Text-Formatierung)
  • Das leidige Problem mit der Bindestrich-Taste ist behoben.
Verbesserungen
  • Die Icons wurden runderneuert und sehen nicht mehr so langweilig aus.
  • Die Optionen des Menüs "Bearbeiten" sind jetzt nur dann verfügbar, wenn es auch Sinn macht.
  • Neue Funktion: "Umlaute bei Eingabe konvertieren" ändert die Buchstaben Ä,Ö,Ü,ß,ä,ö,ü automatisch in die Entsprechungen Ae, Oe, Ue, ss, ae, oe, ue.
  • Neue Funktion: "Exportieren"->"Zeilenende ohne CarriageReturn (Unix/Linux)" ermöglicht es, Dateien an einen Unix/Linux-Rechner zu übergeben, ohne daß das überflüssige CarriageReturn (ASCII-Wert 13) mitgeliefert wird (äußert sich unter Unix meist durch ein ^M am Zeilenende).
  • Die Formatierungsdialoge teilen sich nicht mehr einen Wert, sondern es wurde jedem Dialog eine eigene Variable gegeben


Update von Version 1.1 auf Version 1.2

Verbesserungen
  • Die Geschwindigkeit bei der Verarbeitung größerer Dateien wurde deutlich verbessert. Grund hierfür ist u.a. ein neuer Algorithmus zur Bestimmung der Anzeige von Zeile und Spalte. Diese Verbesserung ist zwar die einzige Änderung, sie ist jedoch so elementar, daß sie mir eine neue Versionsnummer wert war :-)


Update von Version 1.0 auf Version 1.1

Korrekturen
  • Der Name der vorherigen Datei bleibt beim Öffnen einer anderen Datei nicht mehr in der Titelleiste.
  • Die Entf.-Taste kann jetzt auch zwei Zeilen zusammenziehen und sollte insgesamt korrekt arbeiten.
  • Ein Speicherfehler in der Autotext-Verwaltung, der zu willkürlichen Abstürzen führen konnte, ist behoben.
  • Die Bindestrich-Taste (neben der rechten Shift-Taste) wurde größtenteils "wiederbelebt".
  • Die Dateizuordnung im Menü "Eigene Vorlagen" wurde korrigiert. Hier konnte es zu Fehlern kommen, wenn zuvor Dateien aus anderen Verzeichnissen als dem MHS ASCII-Editor-Verzeichnis geladen wurden.
  • Das Neu-Einlesen nicht vorhandener Dateien ist jetzt auch unterbunden worden
  • Die Pfadzuordnung wurde bereinigt. Das Programm findet sich selbst jetzt auch, wenn es über den "Senden an"-Befehl Daten erhält
  • Beim Freischalten bleiben jetzt die Dateiinformationen in der Titelzeile erhalten
  • Die Ersetzen-Funktion sollte jetzt korrekt funktionieren
Verbesserungen
  • Beim Abbrechen des Öffnen-Vorgangs bleibt jetzt das vorherige Dokument erhalten.
  • Es wurde eine Funktion zum "virtuellen Zeilenumbruch" eingefügt. :-)
  • Die Statusleiste zeigt jetzt die Dateigröße in Byte an.
  • Im Menü "Datei" werden jetzt unter "Neu öffnen" die vier zuletzt verwendeten Dateien angezeigt.
  • Die numerischen Eingabefelder diverser Dialoge akzeptieren jetzt auch tatsächlich nur numerische Eingaben.
  • Druckerfont und Editorfont sind jetzt frei wählbar
  • Es wurde ein Format-Menü eingeführt, welches die Möglichkeit bietet, Text zu zentrieren, links oder rechts auszurichten oder auch einzurücken. Auch kann an einer gegebenen Position automatisch ein Zeilenumbruch eingefügt werden.
  • Das Hauptmenü wurde neu strukturiert und sollte jetzt übersichtlicher sein
  • Das Startlogo ist jetzt abschaltbar
  • Ersetzungen der Autotext-Funktion können jetzt so rückgängig gemacht werden, daß Sie nicht gleich wieder ersetzt werden.
  • Es wurden mehrere neue Tastenkombinationen eingebaut
  • Es besteht jetzt die Möglichkeit, die Windows-Zeichentabelle zu starten
  • Vorlagen können entweder in den aktuellen Text eingefügt werden oder diesen ersetzen (vorher war nur letzteres möglich)
  • Dem Editor-Fenster wurde ein Kontextmenü spendiert, ebenso dem Autotext-Dialog


Copyright 2003..05 by Mathias Harbeck ··· Impressum
Aktueller Browser (IE5+, Netscape6+, Opera6+) und aktiviertes JavaScript empfohlen.