Bisherige Updates zu MHS Überweisung 2.x

Aktuelle Version: 2.17 vom 08.10.2016
Produktbeschreibung | Häufige Fragen

Auf dieser Seite finden Sie Informationen zu sämtlichen bereits erstellten Updates (neueste zu oberst). Die aktuelle Version können Sie immer auf der Download-Seite herunterladen.

Update von Version 2.16 auf Version 2.17 (08.10.2016)

Korrekturen
  • Wenn die eingefügten Konto-Daten aus einer der beiden Datenbanken stammten, wurde beim Einfügen in die "Getätigte Ausdrucke"-Datenbank bei den neueren SEPA-Formularen ggf. die Datensatz-ID nicht sauber zugeordnet (hat derzeit allerdings keine nennenswerten negativen Auswirkungen). Dies wurde behoben.
  • Beim Ausdruck wurden die Formulardaten nicht zwischengespeichert, so dass bei schnell nach Start des Ausdrucks veränderten Daten ggf. die neuen Daten für das Einfügen in die "Getätigte Ausdrucke"-Datenbank, in die Konten-Datenbanken sowie für die Vorgaben verwendet wurden. Dies wurde behoben.
  • Beim Ausdruck wurden die Formulardaten nicht zwischengespeichert, so dass bei extrem schnell nach Start des Ausdrucks veränderten Daten ggf. die neuen Daten für Feldprüfungen und den Ausdruck verwendet wurden. Dies wurde behoben.
  • Der Hilfetext zur Quittungsfunktion war bzgl. der Druckposition etwas ungenau (die Werte dort sind nicht relativ zum Überweisungsträger, sondern relativ zur Seite). Dies wurde korrigiert.
Verbesserungen
  • Freischaltcodes können nun direkt vom Shareware-Hinweis aus eingegeben werden.
  • Fehlermeldung bei Freischaltproblemen präzisiert.
  • Kontonummern-Prüfverfahren 74 wurde aktualisiert (Verfahren wird zum 05.12.2016 um eine zusätzliche Variante "2" erweitert; betroffene Kreditinstitute lt. BLZ-Datei vom 05.09.2016: Förde Sparkasse (BLZ 21050170)).
Sonstiges
  • Die Standard-Reihenfolge der Formulare wurde geändert, die SEPA-Formulare stehen nun an erster Stelle. Die Reihenfolge kann natürlich wie bisher jederzeit angepasst werden; sofern Sie diese Option bereits genutzt haben, hat diese Änderung auf Sie i.d.R. keine Auswirkungen.
  • IBAN-Konverter: Die interne BLZ-Datenbank des Konverters wurde aktualisiert (Daten gültig ab 05.09.2016).
  • Aktualisierte BLZ- und BIC-Datenbank (konvertiert jeweils 21.08.2016; gültig ab: 05.09.2016; offizielle Datenbank vom Server der dt. Bundesbank (gefiltert))

Update von Version 2.15 auf Version 2.16 (18.08.2015)

Korrekturen
  • Datenbanktreiber: in Einzelfällen kam es zu einer Meldung, dass "x Felder gefunden, x erwartet" seien (x war jeweils der gleiche Wert). Dies wurde korrigiert, der zweite Zahlwert wird nun korrekt ausgegeben. Zudem wird künftig die Zeile in der Datenbankdatei ausgegeben, die den Fehler verursacht.
  • Datenbanktreiber: Tabulatoren in Datenbankfeldern wurden nicht sauber ausgefiltert, was u.U. zu einer korrupten Datenbank führen konnte. Dies wurde korrigiert.
  • Kontonummernprüfer: das Prüffenster erzeugte beim Öffnen ggf. eine Fehlermeldung, dass ein unsichtbares Fenster keinen Fokus erhalten könne. Dies wurde korrigiert.
  • Kontonummernprüfer: das Prüffenster sollte eigentlich abhängig vom angezeigten Formular die korrekte Registerseite anzeigen; angezeigt wurde jedoch immer die zweite Seite für nationale Kontonummern. Dies wurde korrigiert.
Verbesserungen
  • Kontonummern-Prüfverfahren E2 wurde hinzugefügt (Verfahren wurde zum 08.06.2015 gültig; betroffene Kreditinstitute lt. BLZ-Datei vom 07.09.2015: Landesbank Berlin - E 4 - (BLZ 10050008)).
  • Kontonummern-Prüfverfahren 87 wurde aktualisiert (Verfahren wird zum 07.09.2015 um eine zusätzliche Methode "D" erweitert; betroffene Kreditinstitute lt. BLZ-Datei vom 07.09.2015: Sparda-Bank Baden-Württemberg (Deutschland; BLZ 60090800)).
  • Ausdruck: Neue Druckpositions-Einstellung "Von Längenbeschränkung ausnehmen (bei inaktivem K.-druck)" um bei einzelnen Feldern die eingeschaltete Feldlängenbeschränkung individuell wieder zu deaktivieren (sofern die Feldlängenbeschränkung nicht aufgrund des Kästchendrucks aktiviert wurde und der Kästchendruck nicht ebenfalls individuell deaktiviert wurde).
Sonstiges
  • IBAN-Konverter: Die interne BLZ-Datenbank des Konverters wurde aktualisiert (Daten gültig ab 07.09.2015).
  • Aktualisierte BLZ- und BIC-Datenbank (konvertiert jeweils 02.08.2015; gültig ab: 07.09.2015; offizielle Datenbank vom Server der dt. Bundesbank (gefiltert))

Update von Version 2.14 auf Version 2.15 (28.08.2014)

Korrekturen
  • In Version 2.14 hatte sich ein Fehler eingeschlichen, der den Beleg ein Stück nach links verschob. Dies wurde korrigiert.

Update von Version 2.13 auf Version 2.14 (17.08.2014)

Korrekturen
  • Hauptfenster: Die Autovervollständigung schlug ggf. bei automatisch (z.B. per Vorgaben) eingefügten Feldwerten an und schlug Auswahlmöglichkeiten vor, obwohl dies im Kontext nicht sinnvoll war bzw. das jeweilige Feld gar nicht aktiv war. Dies wurde behoben.
  • Formular-Einstellungen, Erweitert: Bei EU-Standard und SEPA wurde auf der Registerseite "Einzahler-BIC" eine Text-Korrektur vorgenommen ("Beim Einfügen aus der Einzahler-Konten-Datenbank BIC übernehmen" statt bisher "Beim Einfügen aus der Einzahler-Konten-Datenbank BLZ übernehmen")
Verbesserungen
  • Kontonummern-Prüfverfahren 90 wurde aktualisiert (Verfahren wurde zum 09.06.2014 erweitert und zum 08.09.2014 korrigiert; betroffene Kreditinstitute lt. BLZ-Datei vom 08.09.2014: Sparda-Bank Südwest (BLZ 55090500)).
  • Formular-Einstellungen: Bei den SEPA-Formularen und dem EU-Standard-Formular wurde die Option "Auf Beleg führendes 'DE' ebenfalls entfernen" hinzugefügt, um Formulare zu unterstützen, die zwar auf dem Hauptformular ein "DE" vordrucken, aber auf dem Beleg nicht (z.B. Sigel ZV 570)
  • Formular-Einstellungen, Erweiterte Druck-Einstellungen: Neue Option "Zeichenpos. ausblenden (Beleg)", um das Ausblenden von Zeichen gezielter steuern zu können und dies ggf. nur auf dem Beleg (oder eben gerade nicht dort) ausführen zu lassen.
  • Formular-Einstellungen, Erweiterte Druck-Einstellungen: Neue Option "Vom Kästchendruck ausnehmen", um einzelne Felder beim kästchenweisen Druck von diesem ausnehmen zu können.
  • Support-Datei erstellen: Die System-Informationen aus der Selbstdiagnose-Ansicht werden nun automatisch mitgespeichert, um den Support weiter zu erleichtern.
  • Selbstdiagnose: Verfügbarkeits-Informationen über die PlugIn-Verzeichnisse wurden ergänzt.
Sonstiges
  • IBAN-Konverter: Die interne BLZ-Datenbank des Konverters wurde aktualisiert (Daten gültig ab 08.09.2014).
  • Aktualisierte BLZ- und BIC-Datenbank (konvertiert jeweils 10.08.2014; gültig ab: 08.09.2014; offizielle Datenbank vom Server der dt. Bundesbank (gefiltert))
  • Hilfedatei aktualisiert
  • Bestellinformationen aktualisiert

Update von Version 2.12 auf Version 2.13 (20.04.2014)

Korrekturen
  • Textbausteindatenbank: Fehlerbehandlung optimiert.
  • Textbausteindatenbank: Beim Drag&Drop verschwand u.U. das Icon des jeweiligen Eintrags. Dies wurde korrigiert.
  • Die Option "Zulässige Textlänge in den Eingabefeldern begrenzen" funktionierte bei SEPA- und EU-Standard-Formularen für die Felder Einzahler/Name, Begünstiger/Name sowie die Verwendungszwecke nicht richtig (war entweder inaktiv oder auf 35 Zeichen eingestellt). Dies wurde korrigiert.
  • Wurden im Druck-Dialog die Drucker-Eigenschaften aufgerufen, sprang nach dem Schließen der Drucker-Eigenschaften der Druck-Dialog u.U. hinter das Hauptfenster, so dass im ungünstigsten Fall die Anwendung wie abgestürzt wirkte. Dies wurde korrigiert.
Verbesserungen
  • Für jedes Formular kann jetzt ein Hintergrundbild für den Ausdruck konfiguriert werden (via Erweiterte Formular-Einstellungen).
  • Textbausteindatenbank: Einträge können jetzt per Drag&Drop sortiert werden.
  • IBAN-Konverter: Die Umrechnungsregeln wurden an die "Übersicht der IBAN Regeln" vom März 2014 angepasst.
  • "Getätigte Ausdrucke"-Datenbank: Der Listendruck enthält nun eine Option zur zeitlichen Eingrenzung der zu druckenden Einträge.
Sonstiges
  • Der Hintergrund der gedruckten Felder wurde von weiß auf transparent geändert (rein technische Änderung um Hintergrundbilder zu erlauben; bisher i.d.R. ohne Auswirkung).
  • IBAN-Konverter: Die interne BLZ-Datenbank des Konverters wurde aktualisiert (Daten gültig ab 03.03.2014).
  • Aktualisierte BLZ- und BIC-Datenbank (konvertiert jeweils 18.04.2014; gültig ab: 03.03.2014; offizielle Datenbank vom Server der dt. Bundesbank (gefiltert))
  • Fehlermeldungen des Freischaltprozesses wurden um Hinweise zu gängigen Eingabefehlern erweitert.
  • Kleinere (optische) Anpassungen beim Formular "SEPA" zur Umsetzung des "Merkblatt (2013) - Aktualisierung zu den 'Richtlinien für einheitliche Zahlungsverkehrsvordrucke (2009)'".
  • Hilfedatei aktualisiert
  • Die Windows-Versionen 98 und ME werden offiziell nicht mehr unterstützt (derzeit betrifft dies nur das Installationsprogramm; sollten Sie das Programm lizenziert haben und tatsächlich noch diese alten Versionen verwenden, so kontaktieren Sie mich bei Bedarf bzgl. einer Update-Lösung ohne Installationsprogramm).

Update von Version 2.11 auf Version 2.12 (05.01.2014)

Korrekturen
  • Wurde in den Windows-Systemeinstellungen Dezimaltrennzeichen abweichend vom Komma definiert, konnte dies besonders in den Einstellungsdialogen ggf. zu Fehlermeldungen führen. Dies wurde behoben, die Anwendung setzt den Dezimaltrenner nun für sich global auf das Komma.
  • Programm-Einstellungen, dort die Quittungs-Einstellungen: der Menü-Eintrag "Eintrag bearbeiten" im Listenfeld war ohne Funktion. Dies wurde korrigiert.
  • Quittungs-Druck: Die Schriftart-Einstellungen für die einzelnen Quittungsfelder hatten keinen Effekt auf den Ausdruck. Dies wurde korrigiert.
  • Quittungs-Druck: Beim Ausdruck wurde der Wert für den Betrag bei den Formularen "SEPA neutral", "SEPA Referenz" sowie "SEPA Spende" nicht gedruckt. Dies wurde korrigiert.
  • Fehler beim Anzeigen von Windows-Standarddialogen (Schriftarten-Auswahl, Drucker-Auswahl) werden nun sauberer abgefangen.
  • Bei den Formularen "SEPA neutral", "SEPA Referenz" sowie "SEPA Spende" wurde die Laufweite der Einzahler-BIC bei kästchenweisem Druck auf der falschen Basis (sonstige Felder) berechnet. Dies wurde korrigiert, die Laufweite wird nun basierend auf der Kästchen-Einstellung für IBANs berechnet.
Verbesserungen
  • Kontonummern-Prüfverfahren E1 wurde hinzugefügt (Verfahren wird zum 09.12.2013 gültig; betroffene Kreditinstitute lt. BLZ-Datei vom 09.12.2013: Vietnam Joint Stock Commercial Bank for Industry and Trade (BLZ 50131000)).
  • Neue Einträge im Hauptmenü unter "Datenbanken"->"Service": "Verzeichnisse"->"Konfigurationsverzeichnis", "Verzeichnisse"->"Datenverzeichnis", "Verzeichnisse"->"'Eigene Konten'-Datenbank", "Verzeichnisse"->"'Empfänger-Konten'-Datenbank" und "Verzeichnisse"->"'Getätigte Ausdrucke'-Datenbank", jeweils zum einfacheren Zugriff auf die jeweiligen Verzeichnisse.
  • Selbstdiagnose-Dialog: Programm-Info enthält unter "Pfade" zwei neue Angaben "Konfigurationsverzeichnis" und "Datenverzeichnis", um das manuelle Verwalten der Datenablage/-sicherung zu erleichtern.
  • Selbstdiagnose-Dialog: System-Info erkennt nun auch Windows 8.1 und Windows Server 2013 R2.
  • Bei den Druckpositions-Eigenschaften der einzelnen Felder kann nun optional ein Wert "Zeichenpos. ausblenden" angegeben werden, der angibt, welche Bereiche des Textinhalts beim Druck durch Leerzeichen ersetzt werden sollen (sinnvoll z.B. bei IBANs, wenn Ihre Bank einzelne Teile der IBAN bereits vorgedruckt hat; Achtung, die Funktion funktioniert nur sinnvoll in Verbindung mit dem Kästchendruck!).
  • Neue Funktion im "Extras"-Menü: "IBAN-Rechner" zur Umrechnung von Kontonummer und BLZ in IBAN und BIC (unter Berücksichtigung der Sonderfälle der "Übersicht der IBAN-Regeln" der Bundesbank Stand Dezember 2013).
  • Neue Schaltfläche im "Konto bearbeiten"-Dialog der "Empfänger-" und "Eigene Konten"-Datenbanken: "IBAN/BIC erzeugen" zur Umrechnung von Kontonummer und BLZ in IBAN und BIC (unter Berücksichtigung der Sonderfälle der "Übersicht der IBAN-Regeln" der Bundesbank Stand Dezember 2013). Achtung: die Schaltfläche ist nur verfügbar, wenn noch keine IBAN/BIC eingetragen wurden und Kontonummer/BLZ vorhanden sind.
  • Neue Funktion im Hauptmenü unter "Datenbanken"->"Service": "IBAN-Umrechner"->"'Eigene Konten'-Datenbank" und "IBAN-Umrechner"->"'Empfänger-Konten'-Datenbank" zur stapelweisen Umrechnung von Kontonummer und BLZ in der jeweiligen Datenbank in IBAN und BIC (unter Berücksichtigung der Sonderfälle der "Übersicht der IBAN-Regeln" der Bundesbank Stand Dezember 2013).
  • Selbstdiagnose-Dialog: Programm-Info enthält unter "Storage-Subsystem" jetzt auch eine Liste der jeweils verwalteten Datendateien (sprich: die Pfade zu "Eigene Konton"-, "Empfänger-Konten"- und "Getätigte Ausdrucke"-Datenbanken).
  • Selbstdiagnose-Dialog: Programm-Info leicht überarbeitet (enthält nun ein Kontextmenü zum leichteren Auswählen und Kopieren von Einträgen; Pfadangaben enthälten überwiegend eine Angabe zur Beschreibbarkeit der Datei; Fehler bei Dateipfaden werden rot hervorgehoben).
  • Kontonummern-Prüfverfahren 66 wurde aktualisiert (Verfahren wurde zum 03.03.2014 dahingehend geändert, dass für Stammnummer 9 eine Ausnahme (keine Prüfziffernberechnung) hinzugefügt wurde; betroffene Kreditinstitute lt. BLZ-Datei vom 09.12.2013: Credit Suisse (Deutschland; BLZ 50120500)).
Sonstiges
  • Quittungs-Druck: Beim Ausdruck wird der Wert für die Währung bei den Formularen "SEPA", "SEPA neutral", "SEPA Referenz" sowie "SEPA Spende" nun auf "EUR" gesetzt (statt vorher leer).
  • Der Dialog zum Bearbeiten einzelner Druckpositionswerte wurde etwas umgestaltet, um die Bedienung zu vereinheitlichen.
  • Aktualisierte BLZ- und BIC-Datenbank (konvertiert jeweils 03.01.2014; gültig ab: 09.12.2013; offizielle Datenbank vom Server der dt. Bundesbank (gefiltert))
  • Hilfedatei aktualisiert

Update von Version 2.10 auf Version 2.11 (30.09.2013)

Korrekturen
  • Beim Einfügen von Daten aus der "Getätigte Ausdrucke"-Datenbank in die Formulare "SEPA neutral", "SEPA Referenz" und "SEPA Spende" wurden diese fälschlicherweise in das EU-Standard-Formular eingefügt. Dies wurde behoben.
  • Beim Einfügen von Daten aus der "Getätigte Ausdrucke"-Datenbank wurde u.U. bei aktiven Feldern die Autovervollständigung eingeblendet. Dies wurde korrigiert.
  • In den Listen der "Getätigte Ausdrucke"-Datenbank, der Konten-Datenbanken und der BLZ/BIC-Datenbanken verschob eine Bewegung des Mausrads auch die Selektion. Dies wurde deaktiviert.
  • Im Unterdialog "Positionswerte bearbeiten" des Dialogs zur Druckpositions-Einstellung war es möglich, ungültige Zeichen über die Zwischenablage in die Eingabefelder einzuschleusen und damit beim Speichern das Programm in einen Fehlerzustand laufen zu lassen. Dies wurde korrigiert, die Felder werden nach dem Einfügen nun um ungültige Zeichen bereinigt (im Zusammenhang mit Punkt/Komma wird im Falle von nur einem vorhandenen Punkt und keinem Komma eine Konvertierung zum Komma durchgeführt).
Verbesserungen
  • Kontonummern-Prüfverfahren 57 wurde aktualisiert (Verfahren wurde zum 09.09.2013 dahingehend geändert, dass für Kontonummern, die (zehnstellig aufgefüllt) mit 74 beginnen, von Variante 2 zu 1 gewechselt wurde; betroffene Kreditinstitute lt. BLZ-Datei vom 09.09.2013: Targobank (BLZ 30020900)).
  • Kontonummern-Prüfverfahren 95 wurde aktualisiert (Verfahren wurde zum 09.09.2013 dahingehend geändert, dass eine "immer gültig"-Ausnahme für Kontonummern 0910000000 bis 0989999999 hinzugefügt wurde; betroffene Kreditinstitute lt. BLZ-Datei vom 09.09.2013: UniCredit Bank - HypoVereinsbank (BLZ 70020001, 70020270, 70120900)).
Sonstiges
  • Aktualisierte BLZ- und BIC-Datenbank (konvertiert jeweils 26.09.2013; gültig ab: 09.09.2013; offizielle Datenbank vom Server der dt. Bundesbank (gefiltert))
  • Hilfedatei aktualisiert

Update von Version 2.06 auf Version 2.10 (20.05.2013)

Korrekturen
  • Die Konten-Prüffunktion (in den Feldern der nationalen Vordrucke das Hauptfensters) meldete eine unbekannte BLZ, sobald diese Leerzeichen enthielt (z.B. durch die Aufteilungsfunktion). Dies wurde korrigiert, unnötige Leerzeichen werden nun automatisch entfernt.
  • Sofern einzelne Kontenbestandteile in der Datenbank gekürzt wurden (also "[...]" am Ende enthielten), erfolgte die Warnung diesbezüglich beim Einfügen in die Formulare des Hauptfensters auch dann, wenn die im jeweiligen Formular relevanten Felder gar nicht betroffen waren. Dies wurde korrigiert, es wird im Falle von Kürzungen bei IBAN/Konto/BIC/BLZ nur noch dann gewarnt, wenn das entsprechende Feld auch auf dem Zielformular enthalten ist.
  • Sofern eine Kontoverbindung sowohl nationales Konto/BLZ als auch IBAN/BIC enthielt, funktionierte die Prüfung beim Einfügen neuer Kontoverbindungen (u.a. beim Druck oder bei expliziter Anforderung) nicht mehr korrekt (es wurde grundsätzlich eine nicht in der Datenbank enthaltene Kontoverbindung erkannt und folglich ein neuer Datensatz angelegt). Dies wurde korrigiert.
  • Nach dem Einfügen von Daten aus den Konten- oder BLZ/BIC-Datenbanken konnte es passieren, dass sich die Autovervollständigung in einem der Felder öffnete und den gerade eingefügten Eintrag zur Auswahl anbot. Dies wurde korrigiert.
Verbesserungen
  • Neue Formulare "SEPA neutral" (Belegschlüssel 08), "SEPA Referenz" (Belegschlüssel 07) und "SEPA Spende" (Belegschlüssel 06) gemäß "Richtlinien für einheitliche Zahlungsverkehrsvordrucke (2009)".
  • Neue Funktion "SEPA-Referenznummer erzeugen/prüfen..." im "Extras"-Menü zur Berechnung der SEPA-Referenznummer nach ISO 11649:2009 bzw. "Richtlinien für einheitliche Zahlungsverkehrsvordrucke (2009)".
  • Verbesserung der Verständlichkeit des Erstkonfigurations-Dialogs für Speicherorte.
  • Kleinere Überarbeitung des Erstkonfigurations-Dialogs für Formulare.
  • Neue Einstellungsmöglichkeit: Seite "Vorgaben", dort unter "Einzahler", "folgende Daten": "BIC" für die Eingabe einer Vorgabe-BIC für die drei neuen Formulare
  • Neue Einstellungsmöglichkeit: Seite "Vorgaben", dort unter "Verwendungszweck": "SEPA-Referenz" für die Eingabe einer Vorgabe-Referenznummer für das neue SEPA-Referenz-Formular
  • Neue Einstellungsmöglichkeit: Seite "Prüfung", dort unter "Verwendungszwecke": "SEPA-Referenznummern prüfen" für die Prüfung der eingegebenen Referenznummer auf dem neuen SEPA-Referenz-Formular
  • Die Fehlermeldung, die erscheint, sofern beim Druck die eingestellte Schriftart für ein Feld nicht gefunden werden konnte, wurde um Angaben zum betroffenen Feld erweitert, um die Fehlersuche zu erleichtern.
  • SEPA-Formular: das Mehrzweckfeld neben dem Betrag kann nun optional als Empfänger-Bank-Feld konfiguriert werden (in den Einstellungen zum Formular via Button "Erweitert", Seite "Mehrzweckfeld").
Sonstiges
  • Aktualisierte BLZ- und BIC-Datenbank (konvertiert jeweils 20.05.2013; gültig ab: 03.06.2013; offizielle Datenbank vom Server der dt. Bundesbank (gefiltert))
  • Detailänderungen in der Hilfedatei.

Update von Version 2.05 auf Version 2.06 (07.04.2013)

Korrekturen
  • Fehlermeldungen, die beim Speichern von Einstellungen erfolgten, wurden in der Fehlerliste des Selbstdiagnosedialogs fälschlicherweise auf der PlugIn-Seite aufgeführt statt auf der Hauptprogramm-Seite. Dies wurde korrigiert.
  • Der Positionsdialog (zum Bearbeiten der Positionen und Schriftarten von Formular-Feldern) hat nun eine erweiterte Fehlerbehandlung, um Probleme beim Speichern der Werte besser zu erkennen.
  • Die erweiterte Feld-Konfiguration (für Einzahler-BLZ/Einzahler-Bank bei "Inland Sammel", "Inland Lastschrift" sowie "Inland Bankeigen") setzte beim Ausblenden der Formulare die restlichen Optionen nicht auf inaktiv, so dass die Optionen trotzdem aktiv blieben. Dies wurde korrigiert.
Verbesserungen
  • Kontonummern-Prüfverfahren C6 wurde aktualisiert (Verfahren wird zum 04.03.2013 um zusätzliche Nummernkreise erweitert; betroffene Kreditinstitute lt. BLZ-Datei vom 04.03.2013: Landesbank Berlin - E 1 - (BLZ 10050005)).
  • Kontonummern-Prüfverfahren D1 wurde aktualisiert (Verfahren wird zum 04.03.2013 um zusätzliche Nummernkreise erweitert; betroffene Kreditinstitute lt. BLZ-Datei vom 04.03.2013: Landesbank Berlin - E 2 - (BLZ 10050006)).
  • Kontonummern-Prüfverfahren E0 wurde hinzugefügt (Verfahren wird zum 04.03.2013 gültig; betroffene Kreditinstitute lt. BLZ-Datei vom 04.03.2013: -keine-).
  • Neue Funktion "Kontoverbindung einfügen" im "Bearbeiten"-Menü. Diese Funktion erlaubt es, Kontoverbindungen aus der Zwischenablage zu parsen und in die passenden Felder des sichtbaren Formulars zu verteilen (Voraussetzung ist, dass die Kontoverbindungen einem bestimmten Muster folgen: die einzelnen Werte wahlweise durch Zeilenumbruch, Semikolon oder Komma getrennt; jeder Wert wird mit einem passenden Präfix (a la "Kontoinhaber", "Bank" etc.) eingeleitet gefolgt von optionalen Leerzeichen, Doppelpunkten oder Gleichheitszeichen).
  • Über eine neue "Erweitert"-Schalftfläche bei den Formular-Einstellungen kann nun für die Formulare "SEPA" und "EU Standard" Anzeige und Editierbarkeit der (bisher inaktiven) Felder Einzahler-BIC und -Kreditinstitut konfiguriert werden.
  • Schaltfläche "Druckpositionen bearbeiten..." umbenannt in "Erweiterte Druck-Einstellungen".
  • Der Systeminfo-Reiter des Selbstdiagnose-Dialogs erkennt nun auch Windows 8 und Windows Server 2012.
  • Die Support-Datei-erstellen-Funktion packt nun zusätzlich die Vorgängerversion der Logdatei mit ins Paket.
  • Kontonummern-Prüfverfahren 51 wurde aktualisiert (Verfahren wird zum 03.06.2013 um eine zusätzliche Prüfstufe erweitert; betroffene Kreditinstitute lt. BLZ-Datei vom 04.03.2013: Sparda Bank West (BLZ 33060592 und 37060590)).
  • Kontonummern-Prüfverfahren 84 wurde aktualisiert (Verfahren wird zum 03.06.2013 um eine zusätzliche Prüfstufe erweitert; betroffene Kreditinstitute lt. BLZ-Datei vom 04.03.2013: Sparda Bank Augsburg (BLZ 72090500) und Sparda Bank Ostbayern (BLZ 75090500)).
Sonstiges
  • Aktualisierte BLZ- und BIC-Datenbank (konvertiert jeweils 30.03.2013; gültig ab: 04.03.2013; offizielle Datenbank vom Server der dt. Bundesbank (gefiltert))
  • Detailänderungen in der Hilfedatei.
  • Entfall der Newsletter-Option sowie des Telefonnummern-Feldes im Bestell-Assistenten.

Update von Version 2.04 auf Version 2.05 (06.06.2012)

Korrekturen
  • Programmeigenschaften: Im Positionsfenster für die Feldpositionen eines Formulars funktionierten die Kontextmenü-Funktionen zur Übernahme der Schriftart (oder -größe, -name, -stil) von einem Eintrag für alle nicht korrekt und das Programm erzeugte einen Fehler. Dies wurde behoben.
  • Beim Einfügen von Textbausteinen, die mehrere Felder umfassen, gab es auf einigen Formularen wie "Inland bankeigen", "Sammelüberweisung" etc. Probleme, wenn einzelne Felder (speziell Einzahler-BLZ/-Bank) unsichtbar oder nicht editierbar waren. Dies wurde behoben.
  • Erweiterten Formular-Eigenschaften (u.a. bei "Inland bankeigen"): Fehler beim initialen Setzen der Anfangswerte für Einzahler-BLZ/-Bank (EAccessViolation beim Programmstart).
  • Fehler bei der 100er Mehrplatzlizenzberechnung im Bestellassistenten behoben.
  • Schreibfehler im Shareware-Hinweis behoben ("noch" statt "nach").
  • Bei aktivierter Textlängenbeschränkung konnte beim Einfügen aus Zwischenablage oder den Datenbanken trotzdem überlanger Text in die einzelnen Felder eingefügt werden. Dies wird nun verhindert.
  • Das automatische Auflockern der BLZ beim Einfügen aus der BLZ-Datenbank wird bei aktiviertem Kästchendruck (oder generell der Längenbeschränkung) für das aktuelle Formular nun korrekt verhindert.
  • Das automatische Auflockern der BLZ beim Einfügen aus der BLZ-Datenbank funktionierte beim Einfügen via BLZ-Datenbank-Dialog nicht korrekt. Dies wurde behoben.
  • In den optional aktivierbaren Einzahler-BLZ/-Bank-Feldern der Formulare "Inland bankeigen", "Anlage Sammel" und "Lastschrift" wurde bei aktivierter Längenbeschränkung diese nicht aktiviert. Dies wurde behoben.
Verbesserungen
  • Kontonummern-Prüfverfahren D9 wurde hinzugefügt (Verfahren wird zum 04.06.2012 gültig; betroffene Kreditinstitute lt. BLZ-Datei vom 13.05.2012: Bethmann Bank (BLZ 50120383, 50130100, 50220200, 70030800)).
  • Die Einzahler-Datenbank wurde in "Eigene Konten"-Datenbank umbenannt, um Mißverständnisse - insbesondere mit dem Lastschrift-Formular - zu vermeiden.
  • Die Empfänger-Datenbank wird bei Anzeige des Lastschrift-Formular in "Zahlungspflichtigen-Datenbank" umbenannt um Mißverständnisse zu vermeiden.
Sonstiges
  • Aktualisierte BLZ- und BIC-Datenbank (konvertiert jeweils 13.05.2012; Stand: 16.04.2012; gültig ab: 04.06.2012; offizielle Datenbank vom Server der dt. Bundesbank (gefiltert))

Update von Version 2.03 auf Version 2.04 (22.11.2011)

Korrekturen
  • Der Backup-Liste manuell hinzugefügte Datei-Einträge wurden u.U. nicht dauerhaft gespeichert. Dies wurde korrigiert.
  • Bei den Formularen "SEPA-Überweisung" und "EU-Standard-Überweisung" ließ sich eine Einzahler-Kontoverbindung aus dem Kontendialog nur mit "Für alle übernehmen" übernehmen. Dies wurde korrigiert, es steht nun auch der Button "Übernehmen" (zur Übernahme nur in das aktuelle Formular) zur Verfügung.
  • Beim Einfügen manuell definierter Vorgabe-Einzahlerdaten wurde die Kontoprüfung für die eingefügten Daten ggf. nicht korrekt ausgeführt. Dies wurde korrigiert.
  • Das Einfügen der Vorgaben beim Programmstart erfolgte anders als vorgesehen nur im ersten Formular. Dies wurde korrigiert, künftig erscheinen die Vorgaben beim Programmstart in allen Formularen.
Verbesserungen
  • Beim EU-Standard-Überweisungsformular ist es nun möglich, beim Einzahler statt einer IBAN alternativ Kontonummer und BLZ einzugeben.
  • Das automatische Backup kann nun auf Wunsch statt beim Programmstart beim Programmende ausgeführt werden.
Sonstiges
  • kleinere Aktualisierungen in der Dokumentation
  • Kompatibilität des Freischaltmechanismus verbessert.
  • Der Datenbanktreiber gibt nun bei fehlerhaften Datenbanken zusätzliche Details (wie z.B. die betroffene Zeilennummer) zur Fehlersuche aus.
  • Leere Zeilen in den Datenbanken führen nun nicht mehr zu einem Integritätsfehler.
  • Weitere Sicherheitsfunktionen für den Datenbanktreiber.

Update von Version 2.02 auf Version 2.03 (17.07.2011)

Korrekturen
  • Durch eine Änderung in Version 2.02 funktionierte die Option "Drucker auf Querformat umstellen" der einzelnen Formulare nicht mehr (der Ausdruck und das Programm blieben bei 2% hängen). Dies wurde behoben.
  • Einstellungs-Dialog, Kategorie "Updates" bzw. "Automatische Update-Suche": Bei Deaktivierung der Update-Suche wurden die Textfelder rund um das Eingabefeld für die Suchhäufigkeit nicht deaktiviert. Dies wurde behoben.
  • Die Autovervollständigung von Einzahler-BLZ und -Bank funktionierte beim BZÜ-Formular nicht richtig. Dies wurde behoben.
Verbesserungen
  • Die Kategorien im Einstellungs-Dialog werden nun gleich vollständig aufgeklappt, um dem Benutzer alle verfügbaren Bereiche direkt zu zeigen.
  • Kontonummern-Prüfverfahren B6 wurde aktualisiert (Verfahren wird zum 05.09.2011 um zusätzliche Nummernkreise erweitert; betroffene Kreditinstitute lt. BLZ-Datei vom 16.06.2011: Saalesparkasse (BLZ 80053762)).
  • Kontonummern-Prüfverfahren D1 wurde aktualisiert (Verfahren wird zum 05.09.2011 um zusätzliche Nummernkreise erweitert; betroffene Kreditinstitute lt. BLZ-Datei vom 16.06.2011: Landesbank Berlin - E 2 - (BLZ 10050006)).
  • Über eine neue "Erweitert"-Schalftfläche bei den Formular-Einstellungen kann nun für die Formulare "Bankeigen", "Anlage Sammel" sowie "Lastschrift" Anzeige und Editierbarkeit der (bisher inaktiven) Felder Einzahler-BLZ und -Kreditinstitut konfiguriert werden.
  • Über eine neue "Erweitert"-Schalftfläche bei den Formular-Einstellungen kann nun für die Formulare "Anlage Sammel" und "Lastschrift" das neue Feld "laufende Nummer" konfiguriert werden (u.a. Druckposition, Anzeige, Editierbarkeit, automatisches Inkrement etc.).
  • Für die "Getätigte Ausdrucke"-Datenbank kann nun eingestellt werden, ob beim Übernehmen eines Eintrags das Datumsfeld (sofern vorhanden) auf den Wert aus dem Eintrag oder auf das aktuelle Datum gestellt werden soll; alternativ ist auch das leerlassen des Feldes möglich.
Sonstiges
  • Aktualisierte BLZ- und BIC-Datenbank (konvertiert jeweils 16.06.2011; Stand: 19.04.2011; gültig ab: 06.06.2011; offizielle Datenbank vom Server der dt. Bundesbank (gefiltert))

Update von Version 2.01 auf Version 2.02 (17.04.2011)

Korrekturen
  • Funktion "Im Internet"->"Nach Programm-Updates suchen": sofern eine neue Version gefunden wurde, konnten die angezeigten Links nichts ausgeführt werden, da die interne Sicherheitsüberprüfung die URLs als ungültig bewertete. Dies wurde behoben.
  • Funktion "Selbstdiagnose", dort Angaben zur Windows-Version: Kleinere Optimierungen.
  • Funktion "Service"->"Import-Funktionen": Bei den Funktionen zum Import von Daten aus Version 1 (Konten, Textbausteine, Getätigte Überweisungen) wurde unter neueren Windows-Versionen beim Klick auf die Ordner-Auswahlschaltfläche (jene mit dem Ordner-Symbol) ein falsches Startverzeichnis gewählt, was zu einer Fehlermeldung führte, die das Programm blockierte/zu blockieren schien. Dies wurde korrigiert.
  • Funktion "Getätigte Ausdrucke": Im Kontextmenü zu einem Eintrag war die Option "Drucken" ohne Funktion. Dies wurde korrigiert.
  • Kleinere Korrekturen in der Hilfedatei.
  • Die PlugIn-Funktionen rund um den Ausdruck erhielten bei aktivierter Drucker-Rand-Korrektur falsche Werte (betrifft keine momentan verfügbaren PlugIns).
  • U.u. wurden bei Auswahl eines anderen Druckers für die Feldbreiten-Prüfung falsche Werte verwendet, was in fehlerhaften Breitenwarnungen endete. Dies wurde behoben.
  • Wurde in Windows Vista oder neuer bei der Erstkonfiguration die Speicherung für Daten und/oder Einstellungen so eingestellt, dass die Daten von allen Benutzern gemeinsam genutzt werden sollen, so machte bei der bisherigen Umsetzung mit der Speicherung im Programmverzeichnis ggf. der VirtualStore einen Strich durch die Rechnung. Künftig wird nun nicht mehr in das Installationsverzeichnis geschrieben, sondern in das dafür vorgesehene zentrale Windows-Datenverzeichnis (betrifft nur Neuinstallationen, bestehende behalten die alte Konfiguration).
  • Die zentrale Konfigurationsdatei, welche die Ablageorte der weiteren Dateien speichert, wird unter Vista und neuer nun im dafür vorgesehenen Verzeichnis und nicht mehr im Programmverzeichnis abgelegt (bestehende Installationen werden beim ersten Aufruf aus der im Installationsverzeichnis abgelegten Datei aktualisiert; Achtung: dies kann in Mehrbenutzerumgebungen bei Nutzung des VirtualStore ggf. dazu führen, dass für einzelne Benutzer ggf. andere Pfade verwendet werden, als bei der Ersteinrichtung konfiguriert wurden (dies setzt jedoch voraus, dass die Benutzer jeweils unterschiedliche Konfigurationen hatten)).
  • &-Zeichen im Benutzernamen wurden im About-Dialog nicht dargestellt. Dies wurde behoben.
Verbesserungen
  • Funktion "Getätigte Ausdrucke": Das Detail-Fenster zu einem Eintrag ist nun in der Breite vergrößerbar.
  • Kontonummern-Prüfverfahren C6 wurde aktualisiert (Verfahren wird zum 06.06.2011 um zusätzliche Nummernkreise erweitert + Verfahren wurde zum 07.06.2010 um zusätzliche Nummernkreise erweitert; betroffene Kreditinstitute lt. BLZ-Datei vom 19.01.2011: Landesbank Berlin E1 (BLZ 10050005)).
  • Kontonummern-Prüfverfahren D1 wurde aktualisiert (Verfahren wurde zuletzt zum 07.03.2011 weitgehend umgestellt; betroffene Kreditinstitute lt. BLZ-Datei vom 19.01.2011: Landesbank Berlin E2 (BLZ 10050006)).
  • Kontonummern-Prüfverfahren D4 wurde hinzugefügt (Verfahren wurde zum 07.06.2010 gültig + Verfahren wird zum 06.06.2011 um zusätzliche Nummernkreise erweitert; betroffene Kreditinstitute lt. BLZ-Datei vom 19.01.2011: Landesbank Berlin E3 (BLZ 10050007)).
  • Kontonummern-Prüfverfahren D5 wurde hinzugefügt (Verfahren wurde zum 06.12.2010 gültig; betroffene Kreditinstitute lt. BLZ-Datei vom 19.01.2011: Sparda-Bank Hamburg (BLZ 20690500)).
  • Kontonummern-Prüfverfahren D6 wurde hinzugefügt (Verfahren wurde zum 07.03.2011 gültig; betroffene Kreditinstitute lt. BLZ-Datei vom 19.01.2011: Stadtsparkasse Wedel (BLZ 22151730)).
  • Leerzeichen in BLZ/BIC/Kontonummer/IBAN werden nun beim Ausdruck automatisch entfernt, wenn der kästchenweise Ausdruck für das jeweilige Formular aktiviert ist.
  • Neue Funktion "Support-Datei erstellen" zum vereinfachten Zusammenstellen von Konfigurationsdateien für die Einsendung bei Supportfällen.
  • Die Funktion "BLZ-Analyse" gibt nun zu Bankplätzen die zugehörige Bundesbankfiliale aus (sofern zuordnebar).
  • Die Dialoge "Getätigte Ausdrucke-Datenbank", "Einzahler-Datenbank", "Empfänger-Datenbank", "BLZ-Datenbank", "BIC-Datenbank" sowie "Eigenschaften von Konto" lassen sich nun per Escape-Taste schließen.
  • Im Dialog "Eigenschaften von Konto" wird per Enter-Taste nun der Speichern-Button aktiviert.
  • Ausführbare Datei und Installationsprogramm sind nun signiert.
  • Das Programm ist nun auch offiziell für Windows 7 (32 und 64 bit) freigegeben.
  • Kontonummern-Prüfverfahren B8 wurde aktualisiert (Verfahren wird zum 06.06.2011 um einen dritten Schritt erweitert, der bestimmte Nummernkreise von der Prüfziffernberechnung ausnimmt; betroffene Kreditinstitute lt. BLZ-Datei vom 19.01.2011: Landesbank Berlin/Berliner Sparkasse (BLZ 10050000)).
  • Kontonummern-Prüfverfahren D7 wurde hinzugefügt (Verfahren wird zum 06.06.2011 gültig; betroffene Kreditinstitute lt. BLZ-Datei vom 19.01.2011: noch keine).
  • Kontonummern-Prüfverfahren D8 wurde hinzugefügt (Verfahren wird zum 06.06.2011 gültig; betroffene Kreditinstitute lt. BLZ-Datei vom 19.01.2011: noch keine).
Sonstiges
  • Aktualisierte Bestelldaten/-formulare.
  • Aktualisierte BLZ- und BIC-Datenbank (konvertiert jeweils 13.02.2011; Stand: 19.01.2011; gültig ab: 07.03.2011; offizielle Datenbank vom Server der dt. Bundesbank (gefiltert))

Update von Version 2.0 auf Version 2.01 (01.02.2010)

Korrekturen
  • Die Datenbank "Getätigte Ausdrucke" speicherte u.U. fehlerhafte Verweise in die Einzahler-/Empfänger-Datenbank, falls der jeweilige Einzahler/Empfänger dort noch nicht vorhanden war. Dies konnte zum Problem werden, wenn die fehlerhaften Verweise Zeilenumbrüche enthielten (im Ergebnis konnte die Datenbankdatei unlesbar werden). Dies wurde behoben; die fehlerhaften Verweise werden zudem beim ersten Start nach dem Update automatisch korrigiert.

Update von Version 2.0 beta 5 auf Version 2.0 (22.12.2009)

Korrekturen
  • Bei Übernahme eines Eintrags aus der Autovervollständigen-Liste blitzte die Liste ggf. beim Folgefeld kurz auf. Dies wurde behoben.
  • Die Programm-Informationen im Selbstdiagnose-Dialog wurden auf älteren Windows-Systemen (<WinXP) u.U. mit fehlerhafter Formatierung dargestellt. Dies wurde behoben.
  • Durch einen Fehler in der Formularanzeige funktionierte das Weiterschalten zwischen den Feldern per Tabulator-Taste nicht wie erwartet. Dies wurde behoben.
  • Im Positionsdialog der einzelnen Formulare besaßen die Positionsvarianten-Optionen für "DIN A4 links oben" und "DIN A6 normal" die gleichen Werte, was zu dem etwas irritierenden Verhalten führte, dass "DIN A6 normal" nicht auswählbar war, sondern stattdessen "DIN A4 links oben" markiert wurde. Dies wurde korrigiert, die beiden Einträge sind nun zusammengefasst.
Verbesserungen
  • Das Programm ist nun auch unter Windows ME lauffähig.
  • Der initiale Konfigurationsdialog wurde erneut überarbeitet.
Sonstiges
  • Abschlussarbeiten Hilfedatei (kleinere Korrekturen und Anpassungen).

Update von Version 2.0 beta 4 auf Version 2.0 beta 5 (01.11.2009)

Korrekturen
  • Im BLZ- und BIC-Datenbankdialog konnte der markierte Eintrag nicht übernommen werden, sofern die Liste nach der Filterung nur ein Element (das markierte) enthielt. Dies wurde behoben.
  • Die Editiereinträge (Kopieren, Einfügen etc.) in den Kontextmenüs der Formularfelder wurden bei Nichtverfügbarkeit noch nicht deaktiviert. Dies wurde korrigiert.
  • Bug im PlugIn-Entlader behoben (unkritisch).
  • Bei der Übernahme von Textbausteinen, insbesondere jenen mit mehreren Elementen, konnte es sein, dass das jeweils nächste zu befüllende Feld fehlerhaft ausgewählt wurde. Dies wurde behoben.
Verbesserungen
  • Das Programm ist nun auch unter Windows 2000 und Windows 98 lauffähig.
  • Ein neuer PlugIn-Verwaltungs-Dialog erlaubt das automatische Installieren und Aktualisieren von PlugIns über das Internet sowie bei Bedarf auch das Löschen.
  • Neue Funktion zur automatischen Update-Suche (für Programm, BLZ-/BIC-Datenbank sowie PlugIns).

Update von Version 2.0 beta 3 auf Version 2.0 beta 4 (06.10.2009)

Korrekturen
  • Im Dialog "Positionswerte bearbeiten" (sowohl für Positionseditor als auch für Quittungseditor) enthielt der Schriftarten-Auswahl-Dialog Auswahlmöglichkeiten für Schriftfarbe sowie sonstige Effekte, welche nicht vom Programm ausgewertet werden. Die überflüssigen Optionen sind nun ausgeblendet.
  • In den Dialogen "Positionswerte bearbeiten" (sowohl für Positionseditor als auch für Quittungseditor) sowie "Positionen bearbeiten" und "Quittung bearbeiten" funktionierten in einigen Eingabefeldern die Tastenkombinationen für Ausschneiden, Kopieren und Einfügen nicht. Dies wurde behoben.
Verbesserungen
  • Die Basis-Konfiguration (Konfigurations-Orte) wurde mit einem erläuternden Einleitungstext versehen und lässt sich nun auch abbrechen.
  • Die Benutzer-Erstkonfiguration wurde mit einem erläuternden Einleitungstext versehen.
  • "Getätigte Ausdrucke" und Einzahler-/Empfänger-Konten erlauben nun zusätzlich zum Einzeldruck auch den Listendruck aller Einträge (verfügbar über die Toolbar).
  • Zusätzliche Update-Prüfung für BLZ- und BIC-Datenbanken inkl. Download- und Installationsfunktion.
  • Der Konto-Prüfungsdialog übernimmt nun ggf. Kontoangaben aus dem aktiven Formular (sofern vorhanden und Cursor im jeweiligen Feld). Zudem wird je nach aktivem Formular die entsprechende Prüfseite angezeigt.
  • Die Kontextmenüs der Eingabefelder in den Formularen im Hauptfenster wurden um kontextrelevante Einträge erweitert.

Update von Version 2.0 beta 2 auf Version 2.0 beta 3 (20.09.2009)

Korrekturen
  • Die Zwischenablagen-Kopierfunktion der Kontendatenbank kopierte das Feld "Vorgabe-Betrag" nicht. Dies wurde behoben.
  • In der Datenbank "Getätigte Ausdrucke" wurden nach dem Öffnen ggf. einzelne Optionen erst verfügbar, wenn in der Liste ein Eintrag ausgewählt wurde (obwohl bereits ein Eintrag ausgewählt war). Dies wurde behoben.
  • Die Auswahlbox für Feldinhalte auf der Seite "Vorlagen" war beim Öffnen sowie beim Vorlagenwechsel leer. Dies wurde geändert, es ist nun zunächst der erste Eintrag der Liste ausgewählt.
Verbesserungen
  • Kleinere Icon-Anpassungen.
  • Die "Getätigte Ausdrucke"-Datenbank und Kontendatenbanken unterstützen nun den Einzelausdruck von Einträgen. Die Art und Weise des Ausdrucks kann, wie schon von den Kopiervorlagen bekannt, über Vorlagen angepasst werden.
  • Die "Getätigte Ausdrucke"-Datenbank und die Kontendatenbanken können nun wahlweise nach CSV, XML und HTML exportiert werden (zu finden im Hauptmenü unter "Service"->"Export...").
Sonstiges
  • Aktualisierte BLZ- und BIC-Datenbanken (Gültig ab 07.09.2009).

Update von Version 2.0 beta 1 auf Version 2.0 beta 2 (30.08.2009)

Korrekturen
  • Im Selbstdiagnose-Dialog wurden neuere Windows-Versionen (nach XP) als "Windows XP" ausgegeben. Es wurden nun alle Versionen bis "Windows 7" zur Erkennung hinzugefügt.
  • In der BLZ- und der BIC-Datenbank waren u.U. bei Suchergebnissen mit nur einem Element die Buttons und sonstigen Optionen zur Übernahme des Datensatzes ausgegraut. Dies wurde behoben.
  • Beim Umschalten des Eigenüberweisungs-Modus wurden die aktuellen Feldinhalte für Einzahler und Empfänger nicht vertauscht. Dies wurde behoben.
Verbesserungen
  • Es werden nun Start-Parameter zum Vorbefüllen der Felder und zum Start eines Ausdrucks unterstützt (vgl. Hilfe-Thema "Start-Parameter").
  • Das Programm merkt sich nun auch die Fensterposition des Hauptfensters. Beim Erststart wird das Fenster zudem auf dem Desktop zentriert.
  • Das Programm unterstützt nun auch PlugIns.